Mach4 Surface Mapping

Steuerungssoftware, CAM, 2D/3D CAD, G-Code Editoren
Antworten
blue-v
Beiträge: 1
Registriert: 27.01.2022, 13:30

Mach4 Surface Mapping

Beitrag von blue-v » 27.01.2022, 14:48

Hallo zusammen!
Habe hier im Forum keinen echten Vorstellungs-Bereich gefunden, darum kurz in 2 Sätzen:
Mein Name ist Lothar und ich wohne im Ruhrgebiet. Bin Ende 50, verdiene mein Geld in der IT und
bearbeite in der Freizeit hin und wieder mal gern Metall.

Dazu gehört auch das gelegentliche Gravieren von Oberflächen, was ich mit einer eher einfachen CNC Fräse erledige.
Diese Fräse habe ich vor Jahren zusammen mit einem PC und einer "Vollversion" von Mach3 erworben.
Im Laufe der Zeit wurde die Fräse von Parallelport auf Pokeys57CNC umgebaut.
Mittels G-Code Ripper habe ich die Oberfläche der zu gravierenden Objekte abgetastet und den
G-Code der Gravur auf die Oberfläche gemappt.
Alles gut so weit.
Dann habe ich irgendwann fest gestellt, dass es sich bei meiner Mach3 Vollversion mitnichten um eine lizensierte Software,
sondern vielmehr um eine Raubkopie handelte.
Also habe ich eine Mach4 Hobby Lizenz erworben und Mach4 installiert.
Nach ein wenig Mühe läuft die Fräse mit Mach4 jetzt so weit gut.
Bis auf das Surface Mapping.
Das bekomme ich einfach nicht zum Laufen (trotz des Supportes durch Newfangled Solutions)
und hoffe nun, dass mir hier jemand auf die Sprünge helfen kann.

Das Problem stellt sich wie folgt dar:
Wenn ich mit dem SurfaceMap Wizard von Mach4 die Oberfläche des Werkstückes (mit 3D-Taster) abtaste,
reagiert die Maschine einwandfrei auf jeden einzelnen Tastpunkt. Der 3D Taster leuchtet auf und Mach4 stoppt und
fährt zum nächsten Punkt. So weit so gut.
Auch bei manuellen Probings mittels G31 Kommando reagiert die Maschine stets einwandfrei.
Sind alle Punkte abgefahren meldet jedoch der Wizard jedes Mal "<beachtliche Anzahl> no touch points"
Die <beachtliche Anzahl> schwankt dabei, ist aber nie Null. Meist sind ca. 1/3 bis die Hälfte der Punkte ungültig.
Das zeigt sich dann auch im erstellten Map-File: Viele Messpunkte haben den Wert "no touch" (im originalen Wizard der
zur Zeit aktuellen Version von Mach4 2.4.0.4612) oder dem im Wizard angegebenen minimalen Z-Wert in einer neueren
Version des Wizard, den mir der Support von NFS zukommen ließ.
Es ist egal, wie oft ich das Probing durchlaufen lasse oder wie das zu probende Gitter aussieht - immer gibt es eine erhebliche Menge
dieser "no touch" Points im Ergebnis.

Korrigiere ich so eine Datei händisch mit plausiblen Werten, scheint das Mapping in Mach4 auch korrekt zu funktionieren:
Die Z-Achse folgt einwandfrei der "abgetasteten" Oberfläche.

Nachdem der Wizard nun ganz klar seine Probleme hatte, habe ich nach Alternativen gesucht.
Früher in Mach3 hatte ich (wie bereits oben geschrieben) den G-Code Ripper verwendet.
Dieser unterstützt seit einigen Versionen auch Mach4.
Leider liefert der G-Code Ripper aber ebenfalls fehlerhafte Ergebnisse.
Koordinaten angetasteter Punkte tauchen doppelt, dreifach oder gar nicht auf.
Das File ist "Kraut und Rüben".
Ein Beispiel (Fläche mit 50x50mm und 5 Tastpunkten in jeder Richtung):

0.0000,0.0000,0.6485
0.0000,0.0000,0.6485
25.0000,0.0000,-0.2068
25.0000,0.0000,-0.2068
37.5000,0.0000,0.7068
50.0000,0.0000,0.3045
0.0000,12.5009,0.0996
25.0000,12.5009,0.3195
37.5000,12.5009,0.6748
50.0000,12.5009,0.3289
50.0000,12.5009,0.3289
12.5000,25.0000,0.6692
25.0000,25.0000,0.3177
25.0000,25.0000,0.3177
37.5000,25.0000,0.4474
0.0000,37.5009,0.0583
12.5000,37.5009,0.0526
25.0000,37.5009,0.2124
25.0000,37.5009,0.2124
50.0000,37.5009,0.2932
50.0000,37.5009,0.2932
0.0000,50.0000,0.1410
12.5000,50.0000,0.5977
37.5000,50.0000,0.6748
50.0000,50.0000,0.2801

Man sieht z.B.: Punkt X0 Y0 taucht 2x auf, X12.5 Y0 gar nicht etc.
Das wird auch bei mehrmaligem Lauf nicht besser. Oder frei nach Asterix: "Die Ergebnisse sind recht bunt, aber nicht die Gewünschten".
Interessantes Nebenergebnis: G-Code Ripper scheint sich an dem fehlerhaften Mapping nicht zu stören. Er lädt klaglos so eine
Datei. Selbst dann, wenn man einen Großteil der Zeilen einfach löscht. Das Fräsergebnis ist natürlich komplett daneben.

Man könnte jetzt sagen: Ok, dann proben wir halt in Mach3 und nutzen die Map in Mach4.
Geht leider nicht. Erstens möchte ich ungern die Raubkopie weiter verwenden (sie ist auch gar nicht mehr installiert) und
zweitens habe ich in der Übergangszeit (während der Einrichtung von Mach4) fest gestellt, dass ein wechselseitiges Nutzen
von Mach3 und Mach4 zumindest mit Pokeys nicht möglich zu sein scheint. Mindestens eines der beiden Programme programmiert
nämlich Pokeys scheinbar komplett um, sodass die Fräse anschließend mit dem jeweils anderen Programm nicht
mehr steuerbar ist und die komplette Grundkonfiguration (alle Achsen, Zuordnungen, Werte,...) neu durchgeführt werden muss.

So, das war jetzt jede Menge Text. Darum jetzt kurz gefragt:
Hat jemand ähnliche Schwierigkeiten mit Mach4 beim Surface Mapping?
Oder funktioniert es bei Euch einwandfrei? Bei Tony von "This old Tony" bei Youtube scheint es zumindest zu laufen.
Hat jemand einen Tipp, was ich noch probieren könnte?

Wäre sehr dankbar, wenn mir jemand helfen könnte. Mir gehen jetzt langsam die Ideen aus.

Vielen Dank!

Lothar

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste