Anycubic Delta Linear Plus

Geräte, Steuerungen, Slicer, Hotends etc.
Benutzeravatar
Wandoo1980
Beiträge: 1099
Registriert: 30.01.2016, 20:36

Re: Anycubic Delta Linear Plus

Beitrag von Wandoo1980 » 15.03.2018, 22:14

Moin Michael
Michael B. hat geschrieben:
15.03.2018, 17:52
Also nun funktioniert alles wieder wie es soll, nur den Extruder kann ich nicht manuell bewegen.
Warum auch immer. Ist das bei diesem Drucker normal? Bei meinem Anet A6 ist das kein Problem.
Doch das geht ;) Schau mal unter Prepare/Move Axis/Move 1mm
tsinus hat geschrieben:
15.03.2018, 20:05
Hallo Sebastian,
gerade habe ich mir die zwei Teile geordert:
http://bit.ly/2GwCc1s
und
http://bit.ly/2FEoTPx
Bin echt mal gespannt.
Hehe, ja geil! Ich bin gespannt wie du mit ihm klar kommst. Bei mir in der Whatsappgruppe haben es mittlerweile alle geschafft ihren zum laufen zu bewegen ;) Meine beiden Drucken wie ein Uhrwerk.

Sobald ich von der Arbeit komme, rennen sie :D

Grüße, Sebastian
"Seute Deern" Eigenbaufräse
Mach3 mit Cismo IP/M und RoyalCNC Addon
iHSV57 Servos von JMC
SK30 WZW
Tutorials und Videos auf meinem YouTube-Kanal

fliegerkind
Beiträge: 296
Registriert: 06.01.2016, 20:18

Re: Anycubic Delta Linear Plus

Beitrag von fliegerkind » 16.03.2018, 16:24

Wandoo1980 hat geschrieben:
15.03.2018, 22:14
Meine beiden Drucken wie ein Uhrwerk.
Der Trend geht eindeutig zum Zweit-Drucker :D

Heini

SirBoss
Beiträge: 14
Registriert: 16.08.2017, 09:16

Re: Anycubic Delta Linear Plus

Beitrag von SirBoss » 16.03.2018, 16:37

...so mein Drucker läuft wieder :D. Der Levelsensor ist repariert. Es war scheinbar nicht nur der Mikroschalter kaputt sondern auch noch eine Leiterbahnunterbrechung vorhanden. Ich habe das ganz professionell gelöst ;) .
IMG_20180316_142049_cr_1.jpg
Grüße Frank

GuiHue

Re: Anycubic Delta Linear Plus

Beitrag von GuiHue » 16.03.2018, 17:41

Ich bin inzwischen auf etwas spektischer - ich habe leider auch nicht den teilmontierten Bausatz sondern den vollständig aus Einzelteilen bestehenden Drucker. Mal sehen was das gibt...

Michael B.
Beiträge: 156
Registriert: 14.01.2018, 09:29

Re: Anycubic Delta Linear Plus

Beitrag von Michael B. » 16.03.2018, 18:45

Hi,

Heute hat mein Anet A6 den Geist aufgegeben XD
Die Linearkugellager sind eingelaufen während einem Druck.
Ich weis jetzt wirklich nicht was ich davon halten soll, aber naja. Wenn die Führung spontan klemmt und wieder einige mm läuft.

Gut wenn jetzt der neue Drucker laufen würde.

Gruß Michael

Edit: Stück für Stück komme ich einem funktionierenden Delta näher, eine funktionierende Firmware habe ich gefunden.
Der Extrudermotor habe ich nun versuchsweise auf den zweiten Z Achsentreiber gesteckt, dort funktioniert er.
Witzigerweise habe ich eben den Treiber der Z Achse und den Stecker des Motors zurück auf die eigentliche Position gesteckt, dort geht nichts.
Heißt für mich entweder der Signalpin ist tot oder irgendetwas anderes funktioniert nicht.

Ich kämpf mich mal durch die Firmware und versuch den Pin auf die Z Achse 2 zu ändern.
Nebenbei muss ich glaube ich noch 2 Werte Anpassen.

Philipp_Muc
Beiträge: 10
Registriert: 21.02.2018, 13:29

Re: Anycubic Delta Linear Plus

Beitrag von Philipp_Muc » 16.03.2018, 19:47

Ich habe mich heute mit meinem Drucker etwas auseinandergesetzt und die Verkabelung geprüft sowie alles sauber verlegt. Ich meine es hat sich zwar eigtl nichts geändert, aber nun bewegen sich zumindest mal alle drei Motoren beim homing und fahren korrekt auf die Endschalter. Das "Level bed" hingegen jedoch nicht. Er fährt zwar herunter und versucht anzufahren, jedoch etwa 8cm über dem Heizbett. Beim Versuch einen Punkt zu treffen erscheint dann: "Err: Z-Probe"

Kann mir einer von euch eine funktionierende Firmware zukommen lassen? Am besten von einem Linear Plus wie er ab Werk kommt, Sebastian evtl?

Ich hab zwar die neueste von der anycubic Seite aufgespielt, jedoch vergessen die originale zu sichern.

@Michael B. auch deine Firmware würd ich gern probieren um zu testen. Es kann ja nicht so schwer sein das schöne Gerät in Gang zu bringen...

Mein Extruder lässt sich über "Move axis" übrigens auch nicht bewegen....

Gruß Philipp

Michael B.
Beiträge: 156
Registriert: 14.01.2018, 09:29

Re: Anycubic Delta Linear Plus

Beitrag von Michael B. » 16.03.2018, 20:24

Hi Phillip,

das mit dem Extruder scheint nicht an der Hardware zu liegen. Scheinbar ist das eine fehlerhafte Softwareeinstellung.
Steck mal deinen Extruder auf den zweiten Z Anschluss dann sollte sich der Motor bewegen. War zumindist bei mir so.

Ich bin gerade dabei in meiner Firmware das so umzuschreiben, das mein Extrudermotor auf Z2 läuft anstatt auf E0.

Außerdem will ich den möglichen Offsetwert für die Z Achse noch vergrößern. Bei mir ist Z = 0 10,5mm über dem Heizbett, was irgendwie nicht gut ist.

Wenn ich das angepasst bekommen habe, dann würde ich sie dir zuschicken.

Du hast auch den Linear Plus? Mit oder Ohne Autoleveling?

Achja, ich hab in der Firmware auch schon gefunden, wo der Levelsensor angeschlossen werden muss. Wer also keinen Autolevelsensor hat, der kann einen nachrüsten. Ebenso den Filamentsensor.

I love free code :-)

Grüße Michael

Michael B.
Beiträge: 156
Registriert: 14.01.2018, 09:29

Re: Anycubic Delta Linear Plus

Beitrag von Michael B. » 16.03.2018, 21:18

Hi,
solangsam komme ich weiter:

Das Board ist eine Platine wo die Schaltung eines Arduino und eines RAMPS 1.4 vereint sind.
Davon ausgehend sollte die Treiberpins gleich zu den Pins von Ramps 1.4 sein.

Ich prüfe.

Edit: Pinkompatiblität ist vorhanden, nur das Chip Select ist aktuell nicht drinnen, da schaue ich gerade nach, ...

Gruß

Benutzeravatar
carbonkid
Beiträge: 90
Registriert: 28.09.2016, 16:08

Re: Anycubic Delta Linear Plus

Beitrag von carbonkid » 16.03.2018, 21:33

Also ihr habt ja Stress mit dem Drucker, hoffe das bleibt mir erspart! Bei Sebastian lief das bei beiden ja problemlos.
Habe heute schon mal angefangen und die ganzen Späne entfernt. Einen Motor hab ich gedreht damit das Kabel nicht so über die Platine baumelt, das mag ich ja gar nicht. Bei dem "Profildreieck" unten mußte ich an einem Kunststoffverbinder etwas abschneiden weil der über das Profil herausragte und somit die Aufstandsfläche nicht eben war. Die Metallplättchen womit die Anschläge auf den Aluprofilen, wo die Linearschinen befestigt werden, mußte ich auch etwas zurecht feilen da die sonst nur längs statt quer ins Profil gepasst hätten. Naja alles nur Kleinigkeiten...
Morgen geht es dann fröhlich weiter.

@Michael
Wieso hast du überhaupt eine Firmware aufgespielt, ist die nicht schon von Werk aus drauf?
Gruß Daniel

Fräse : CSMIO-IP-M / JMC-iHSV57 180W / SiMCNC / mini-iTX Asus Celeron 847 / FilouNC
3D Drucker: Anycubic Delta Linear

Michael B.
Beiträge: 156
Registriert: 14.01.2018, 09:29

Re: Anycubic Delta Linear Plus

Beitrag von Michael B. » 16.03.2018, 21:41

Weils in der Anleitung heist Firmware Update,
auf der SD Karte war keins drauf und damit haben meine Probleme angefangen, ...

NOT Amused.

Korrektur:
Es ist die Firmware Version 20161122 drauf, welche beim kompillieren einige Fehler rauswirft. Und die lassen sich ohne Codekenntnis nicht mal eben beheben.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast