Probleme mit Windows 10

Steuerungssoftware, CAM, 2D/3D CAD, G-Code Editoren
Antworten
Hubertus
Beiträge: 30
Registriert: 06.05.2018, 14:53

Probleme mit Windows 10

Beitrag von Hubertus » 04.12.2018, 17:52

Hallo,

ich bin jetzt schon am verzweifeln. Ich habe ein kleines Sketch erstellt und mit meinem alten XP-Rechner an den Arduino gesendet. Funktioniert alles ohne Probleme.
Nun habe ich auch zwei Windows 10 Rechner…Die WIN10 APP für Arduino installiert und..lauter Fehlermeldungen beim Hochladen bei beiden WIN10-Rechnern.

Der Sketch verwendet 3794 Bytes (12%) des Programmspeicherplatzes. Das Maximum sind 30720 Bytes.
Globale Variablen verwenden 460 Bytes (22%) des dynamischen Speichers, 1588 Bytes für lokale Variablen verbleiben. Das Maximum sind 2048 Bytes.

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x65


Die letzte Meldung wird noch 9 mal wiederholt ( attempt 10 of 10)
Hier ein paar Daten:
Windows 10 mit allen Aktualisierungen
Arduino Software = 1.8.7 (Windows Store 1.8.15.0)
USB Converter = USB-SERIAL CH340 aktualisiert

Der COM-Port ist im Arduino richtig ausgewählt, auch die Einstellungen im Editor sind korrekt.
Starte ich Estlcam, so habe ich keine Probleme, alles funktioniert.

Hat jemand einen Rat?

Gruß
Hubertus

Tilman
Beiträge: 33
Registriert: 20.11.2018, 22:02

Re: Probleme mit Windows 10

Beitrag von Tilman » 04.12.2018, 21:52

Hallo Hubertus,

"avrdude: stk500_recv(): programmer is not responding" würde ich als Treiberproblem deuten. Hast Du Windows einen eigenen Treiber laden lassen oder einen passenden UART-Treiber selber gesucht und installiert?

Viele Grüße
Tilman

Hubertus
Beiträge: 30
Registriert: 06.05.2018, 14:53

Re: Probleme mit Windows 10

Beitrag von Hubertus » 04.12.2018, 22:01

Hallo Tilman,

zuerst habe ich bezüglich Treiber nichts unternommen, habe bei der Arduino-Installation einfach alles ausgewählt und bestätigt. Dann habe ich festgestellt, dass WIN10 keinen andern Treiber für den Arduino akzeptiert, es sagt immer, dass der beste Treiber für dieses Gerät bereits installiert ist.
Eigenartiger Weise, habe ich mit Estlcam überhaupt keine Probleme.
Was ist jetzt der Unterschied zwischen dem WIN10 und dem WIN XP Treiber, denn unter XP gibt es keine Probleme.

Gruß
Hubertus

Tilman
Beiträge: 33
Registriert: 20.11.2018, 22:02

Re: Probleme mit Windows 10

Beitrag von Tilman » 04.12.2018, 22:58

Hallo Hubertus,

um was für ein Arduino handelt es sich denn? Und ist es ein Original oder nicht?

Viele Grüße
Tilman

Hubertus
Beiträge: 30
Registriert: 06.05.2018, 14:53

Re: Probleme mit Windows 10

Beitrag von Hubertus » 05.12.2018, 12:16

Hallo Tilman,

nach langen intensiven Tests, sowie Nachforschungen im Internet komme ich jetzt auch zu der Erkenntnis, wer billig kauft, kauft manchmal zweimal. Es handelt sich bei dem Arduino um einen China-Clone. Schließe ich ein Original Arduino an, funktioniert alles ohne Probleme. Dieses Problem scheint aber schon im Internet bekannt zu sein.
Ich werde mich mit dem Lieferant in Verbindung setzen und nach einer Lösung fragen. Verstehe mich nicht falsch, der Clone funktioniert mit dem Sketch, ich muss ihn halt nur mit meinem XP-Rechner hochladen. Bin mal gespannt, was der Lieferant sagt.

Nochmals Danke und Gruß
Hubertus

PitLem
Beiträge: 5
Registriert: 05.12.2018, 08:16

Re: Probleme mit Windows 10

Beitrag von PitLem » 05.12.2018, 12:49

Moin,

schon bekannt ? https://www.makershop.de/ch340-341-usb-installieren/

Es kann auch helfen LibUSB zu installieren. 32Bit läuft auch auf 64Bit Systemen.

Gruß

Hubertus
Beiträge: 30
Registriert: 06.05.2018, 14:53

Re: Probleme mit Windows 10

Beitrag von Hubertus » 05.12.2018, 13:18

Hallo PitLem,

die Info ist gut, doch leider kann ich kein Chinesisch. Den Treiber habe ich zwar heruntergeladen, aber bei der Installation bekam ich eine Einstellungsseite..alles auf Chinesisch :o
Ich will ja nicht einfach irgendetwas auslösen, was gar nicht gewünscht ist.

Gruß
Hubertus

fliegerkind
Beiträge: 277
Registriert: 06.01.2016, 20:18

Re: Probleme mit Windows 10

Beitrag von fliegerkind » 05.12.2018, 15:37

Hallo Hubertus!
Hubertus hat geschrieben:
05.12.2018, 13:18
Den Treiber habe ich zwar heruntergeladen, aber bei der Installation bekam ich eine Einstellungsseite..alles auf Chinesisch :o Ich will ja nicht einfach irgendetwas auslösen, was gar nicht gewünscht ist.
Keine Sorge, den Treiber hast Du ja ohnehin längst installiert, Du hast es sogar selbst oben in Deinem ersten Posting geschrieben:"USB Converter = USB-SERIAL CH340 aktualisiert". Ich hatte vor längerer Zeit mein Mainboard vom 3D-Drucker umgepatched und mit dem Chinaclone drei PCs gebraucht, nur einer davon ging zuverlässig (Win 7). Windows 10 kann, muss aber nicht gehen, was allerdings bei Win 10 generell gilt und nicht nur auf die ch340-Treiber bezogen ist. Ich habe mit Troubles bei Win 10 sicher schon einen ganzen Urlaub meiner Lebenszeit verbracht und ständig tun sich neue Fallen auf, ein Ende ist nicht abzusehen (Stichwort 1809-Update vom Oktober). Also kauf einfach das Original und genieße die ersparte Zeit ;-)

LG, Heini

Hubertus
Beiträge: 30
Registriert: 06.05.2018, 14:53

Re: Probleme mit Windows 10

Beitrag von Hubertus » 05.12.2018, 17:35

Hallo Heini,

du hast völlig Recht. Die Zeit kann ich sinnvoller nutzen als mich mit diesem Mis... zu beschäftigen. Ich habe mir mal die .inf-Datei für den Treiber angeschaut. Siehe hier:

; CH341SER.INF
; Driver for CH341 (USB=>SERIAL chip) V3.4
; WDM&VXD for Windows 98/Me/2000/XP/Server2003/Vista/64bit Vista/Server2008/Win7/64bit Win7
; Copyright (C) W.ch 2001-2014

Daran kann man sehen, dass der Treiber nicht für WIN10 vorgesehen ist. Kompatibilität zwischen WIN 7 und WIN 10 funktioniert halt doch nicht immer.

Danke für deine Info.

Gruß
Hubertus

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste