Nullpunkt wandert

Materialien, Dimensionierung, Lineartechnik..
1.AVM
Beiträge: 287
Registriert: 19.02.2016, 13:46

Re: Nullpunkt wandert

Beitrag von 1.AVM » 23.07.2019, 09:43

Exakt Stop funktioniert nicht besonders gut bei Kreisinterpolation ohne I und J Komponente. Beim Adaptive Clearing wird ein G-Code erstellt, der auf tausenden XY-Koordinaten basiert. Ohne den CV Modus fährt die Maschine hart jeden Punkt an, bremst und beschleunigt wieder.


Ich werd vorerst den OL Stepper auf die Z-Achse bauen, die muss am wenigsten Masse bewegen und macht generell den wenigsten Weg. Ich bin gespannt, ob der Fehler mitwandert.
liebe Grüße

Patrick

django013
Beiträge: 1544
Registriert: 18.01.2016, 17:12

Re: Nullpunkt wandert

Beitrag von django013 » 24.07.2019, 05:03

Ich bin gespannt, ob der Fehler mitwandert.
Naja - solche Aktionen sind nicht besonders klewer :shock:
Normalerweise sollte man erst den Fehler finden und ausmerzen, bevor man größere Änderungen angeht.
Aber sonst - macht das Vorhaben durchaus Sinn.
... auch wenn für mich ein OL-Stepper im Zusammenspiel mit CL-Steppern überhaupt keinen Sinn ergibt.

Gruß Reinhard

1.AVM
Beiträge: 287
Registriert: 19.02.2016, 13:46

Re: Nullpunkt wandert

Beitrag von 1.AVM » 24.07.2019, 07:04

Warum ergibt das keinen Sinn?
Welche Möglichkeit bleibt denn, wenn die Teile fertig werden müssen, ich den Fehler aber nicht lokalisieren kann? :o
liebe Grüße

Patrick

sswjs
Beiträge: 335
Registriert: 23.09.2016, 16:52

Re: Nullpunkt wandert

Beitrag von sswjs » 27.07.2019, 18:18

Moin,
1.AVM hat geschrieben:
22.07.2019, 15:00
Schrittmotor getauscht, Endstufe getauscht, Breakoutboard getauscht - Problem bleibt bestehen.
Kabel mitgetauscht? Das ist übrigens kein Witz, denn mir ist so was ähnliches auch passiert.

Meine Fräse war zur Reperartur beim Hersteller, weil die Y-Achse klemmte. Nach der Reperatur klemmte die X-Achse. Hab mit der Fehlersuche fast 4 Monate gebraucht. Der Hersteller hat mir sogar eine neue Steuerung geschickt, Fehler blieb. Als ich dann einen der Motoren getauscht und die Quetschverbinder durch Wagoklemmen ersetzt hatte, blockierte die andere Seite. Dort ebenfalls die Quetschverbinder entfernt und die X-Achse läuft jetzt sogar mit maximalen Ansteuertakt...

sswjs, aka Jens
Maschinen: High-Z 1000 mit Kress FME-1050/1, Stepcraft 1/600 umgebaut mit Kress FME-1050

1.AVM
Beiträge: 287
Registriert: 19.02.2016, 13:46

Re: Nullpunkt wandert

Beitrag von 1.AVM » 07.09.2019, 09:05

Also: Auflösung des ganzen:


Schrittverluste durch Störungssignale aus der Werkzeugspindel durch schlechte Schirmung.

Manchmal kanns so einfach sein und der Fehler liegt im Detail.

Open Loop Motoren reagieren auf die Einstreuung, closed loop nicht.
liebe Grüße

Patrick

KarlG
Site Admin
Beiträge: 3523
Registriert: 22.12.2015, 22:17

Re: Nullpunkt wandert

Beitrag von KarlG » 07.09.2019, 23:56

1.AVM hat geschrieben:
07.09.2019, 09:05
Open Loop Motoren reagieren auf die Einstreuung, closed loop nicht.
Hmm - ich habe da durchaus ein Problem, das logisch nachzuvollziehen. CL sind bei mechanischen Problemen schon im Vorteil, also: Widerstand zu groß, OL kippt in den nächsten Großschritt, bzw. bleibt einfach stehen und CL kann aufgrund seiner Positionsbestimmung und "boost-Funktion" die Abweichung feststellen und regelt nach.
Bei Einstreuungen ins Motorkabel (mit aufgeprägten Impulsströmen im Amperebereich) kann ich mir einen Einfluss der Spindel eher weniger vorstellen, denn das müssten gigantische Induktionen sein, den Motor aus dem Tritt zu bringen. Andersrum wären Induktionen aufs Step-Signal für OL und CL gleichermaßen schädlich. Persönlich glaube ich, dass nicht der Austausch Cl->OL das Probem gelöst hat, sondern irgendwas anderes (bspw. besssere Abschirmung der Signalkabel/Endstufen).

1.AVM
Beiträge: 287
Registriert: 19.02.2016, 13:46

Re: Nullpunkt wandert

Beitrag von 1.AVM » 08.09.2019, 12:30

Die Kabel sind jedoch gleich geblieben! Vielleicht wars auch die Nähe zur Endstufe, da bei den CL Steppern die Endstufen mit am Motor sitzen und ich das bei den OL Steppern bereits kabeltechnisch vorbereitet hatte und die Endstufe mit in der Nähe des Motors war.
liebe Grüße

Patrick

KarlG
Site Admin
Beiträge: 3523
Registriert: 22.12.2015, 22:17

Re: Nullpunkt wandert

Beitrag von KarlG » 08.09.2019, 22:40

1.AVM hat geschrieben:
08.09.2019, 12:30
..und die Endstufe mit in der Nähe des Motors war.
Das ist schon eher logisch, wobei die Endstufe dann "eigentlich" in Störung gehen müsste. Aber das hängt wohl überwiegend vom design der Endstufen ab.

Was ich eigentlich ausdrücken wollte: Abgesehen von den wirklich unbestrittenen Vorteilen der CL-Systeme, ist es kein sinnvoller Lösungsansatz, bei irgendwelchen undefinierten Problemen OL gegen CL zu tauschen und zu hoffen, dass dann die Probleme weg sind. Man muss das Problem verstehen und dieses auch lösen. Richtig dimensionierte und installierte OL-Systeme laufen auch störungsfrei und ohne Schrittverluste.

1.AVM
Beiträge: 287
Registriert: 19.02.2016, 13:46

Re: Nullpunkt wandert

Beitrag von 1.AVM » 08.09.2019, 23:02

Richtig, das seh ich genauso. Aktuell muss die Maschine aber einfach laufen und ich hab keine Zeit für Instandsetzung nach Lehrbuch. Das nehm ich mir für die Winterzeit vor! Dein Ansatz ist definitiv der richtige, ich nehm ihn mir zu Herzen :)
liebe Grüße

Patrick

KarlG
Site Admin
Beiträge: 3523
Registriert: 22.12.2015, 22:17

Re: Nullpunkt wandert

Beitrag von KarlG » 09.09.2019, 08:18

1.AVM hat geschrieben:
08.09.2019, 23:02
Aktuell muss die Maschine aber einfach laufen...
Das ist verständlich und der Hinweis ging eher in die Richtung, dass die anderen Leser nicht glauben, dass CL ein pauschaler Lösungsweg für diverse Probleme ist. Ich mache das häufig auch nicht anders, dass ich statt systematischer (zeitaufwändiger) Fehlersuche auf Verdacht Teile tausche, weil das einfach billiger ist, oder schlicht die Zeit fehlt.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast